Tuesday, November 2, 2010

Cisco Training Lab Network

I set up a Cisco equipment training lab for myself today using some spare Cisco equipment.  The diagram below outlines the basics of the network that I set up.  You can use this information as a guide for how to set up a basic Cisco training lab!  I'll be doing some more interesting stuff with this setup as time goes on.

TOP is a Cisco 3640 with a few WIC 1DSU T1 controller cards installed.
BOTTOM is a Cisco 3825 router with a few VWIC2-2MFT-T1/E1 controller cards installed.
SMALL is a Cisco 1841 router with one VWIC2-2MFT-T1/E1 controller card installed.
SWITCH is a Cisco Catalyst 2950; a 24 port fast Ethernet switch.

In order to connect the routers back-to-back without an ISP between them, just create some cables that switch wires 1 & 2 with 4 & 5 on one end (normal straight cable on the other end).  If you're comfortable creating straight-through cat5/cat6 cables, just create a cable with OW-O-GW-Bl-BlW-G-BrW-Br on one end and Bl-BlW-GW-OW-O-G-BrW-Br on the other end.  The reason behind this cable wiring is that both routers will be sending on wires 4 & 5 and listening on wires 1 & 2.  Therefore, you must swap these two pairs so that when router 1 sends on 4 & 5, the signal will end up on router 2's listening wires, 1 & 2.

Depending on the router, you may have to set up the controller module before a serial interface even appears:

BOTTOM>enable
BOTTOM#configure terminal
BOTTOM(config)#card type t1 0 0
----- This tells the router that you have a T1 card in slot 0/0. The card's amber light(s) will probably come on now.

BOTTOM(config)#controller t1 0/0/0
BOTTOM(config-controller)#framing esf
BOTTOM(config-controller)#linecode b8zs
BOTTOM(config-controller)#clock source internal
BOTTOM(config-controller)#channel-group 0 timeslots 1-24 speed 64
----- The command above will cause the router to create a serial interface.

BOTTOM(config-controller)#interface s0/0/0:0
BOTTOM(config-if)#encapsulation ppp
BOTTOM(config-if)#ip address 192.168.1.1 255.255.255.252
BOTTOM(config-if)#no shutdown
----- The mask of 255.255.255.252 (192.168.1.1/30) breaks the 192.168.1.0/24 (255.255.255.0) subnet into many smaller subnets with 2 usable IPs each - perfect for point-to-point links!  The 192.168.1.0/30 subnet consists of the following IPs:
-- 192.168.1.0 (network IP)
-- 192.168.1.1 (usable IP - BOTTOM router)
-- 192.168.1.2 (usable IP - TOP router)
-- 192.168.1.3 (broadcast IP)
If you're not comfortable with subnetting information like this, read up on it!  It's very important knowledge for anyone working on routers and switches.

The commands listed above are all that are required (and some are optional) on this router to set up a basic point-to-point interface.  Now, we need to set up the interface on one of our other routers, TOP, which requires a slightly different method because of the different interface card used:

TOP>enable
TOP#configure terminal
TOP(config)#interface s0/0
TOP(config-if)#service-module t1 clock source internal
TOP(config-if)#service-module t1 framing esf
TOP(config-if)#service-module t1 linecode b8zs
TOP(config-if)#service-module t1 timeslots 1-24 speed 64
----- The last 4 commands replace the card and controller configuration commands used on BOTTOM, the last router we configured.

TOP(config-if)#encapsulation ppp
TOP(config-if)#ip address 192.168.1.2 255.255.255.252
TOP(config-if)#no shutdown

We should now have a working, usable point-to-point link between BOTTOM and TOP, as long as you created the cable properly and plugged it into the correct interface on each router.  Try pinging between the routers:

TOP#ping 192.168.1.1
Sending 5, 100-byte ICMP Echos to 192.168.1.1, Timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

Now that you have this link configured, it should be a piece of cake for you to configure the remaining serial links and Ethernet interfaces to complete the network in the picture at the top of this post.

Good luck!  Let me know if you run into any problems!

25 comments:

  1. Great explanation of cisco lab network training, i am working in a training institute which provide this training and i am glad to have this information about cisco training.

    ReplyDelete
  2. I have read your blog its very attractive and impressive. I like it your blog.

    Java Training in Chennai Core Java Training in Chennai Core Java Training in Chennai

    Java Online Training Java Online Training Core Java 8 Training in Chennai Core java 8 online training JavaEE Training in Chennai Java EE Training in Chennai

    ReplyDelete
  3. Java Online Training Java Online Training Java Online Training Java Online Training Java Online Training Java Online Training

    Hibernate Online Training Hibernate Online Training Spring Online Training Spring Online Training Spring Batch Training Online Spring Batch Training Online

    ReplyDelete
  4. This is quite educational arrange. It has famous breeding about what I rarity to vouch. Colossal proverb.
    This trumpet is a famous tone to nab to troths. Congratulations on a career well achieved. This arrange is synchronous s informative impolites festivity to pity. I appreciated what you ok extremely here 


    Selenium training in bangalore
    Selenium training in Chennai
    Selenium training in Bangalore
    Selenium training in Pune
    Selenium Online training

    ReplyDelete
  5. Great post!
    Thanks for sharing this list!
    It helps me a lot finding a relevant blog in my niche!
    Java Training in Chennai
    Java Training in Coimbatore
    Java Training in Bangalore

    ReplyDelete
  6. Learned a lot from your post and it is really good. Share more tech updates regularly.thanks for your information really good and very nice web design company in velachery

    ReplyDelete
  7. Thanks you so much for your efforts blog, If your are looking for a creative mobile app development in mumbai, Appslure provides one of the best and professional app development company in mumbai.
    Mobile app development company in mumbai

    ReplyDelete